Posts Tagged ‘hdparm’

Do not change hdparm parameters while burning a DVD

Wednesday, July 4th, 2007

We all know this, right? In my new system, I have forgotten to activate the DVD-R’s DMA. I tried burning a DVD, and it went slow – real slow.

I have checked the DMA status:

$ hdparm /dev/hda

/dev/hda:
IO_support = 0 (default 16-bit)
unmaskirq = 1 (on)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device

I have rather expected that. After a quick glance, I have activated the DMA, while the DVD was still burning, against all common sense.

# hdparm -d1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
using_dma = 1 (on)

DMA seemed to be on, and I was happy. I noticed that:

a. the burning process did not fail

b. burning speed increased dramatically

I thought I was able to pull this trick off. However, the DVD was unreadable later on, and I noticed an interesting pattern on it, as can be described only by my poor attempt to capture it in a picture:

Notice the “layers”. You can see the transparent plastic (and my own hand holding the DVD) and the black no-data layer (seems green from here, but it is black), and then the regular marks of burned CD, and about one third of the way (sector-wise, it is about fifth or sixth of the way) a change in the pattern of the marks. This goes until the last circle of unburned CD.

Check out this other attempt to capture the texture:

Here the change in the texture is very visible.

A note – this is not a rewritable DVD, and the whole operation went in one go.

Interesting.