Posts Tagged ‘Lucent’

AMR Modem, failure so far

Thursday, July 21st, 2005

As my quest for a fully working laptop is advancing, I have decided to invest my time (or got drawn to it, donno why) in making the modem work. Actually, I’m stuck here. I cannot see the modem’s device in lspci, I have not isapnp devices whatsoever, so I cannot claime it’s an ISA device, and the AMR is supposed to depend on the PCI bus, am I right?

The modem is supposed to be a Lucent AMR modem. According to linmodems, this modem is not supported whatsoever, and never will be. According to some other parts of the internet, this modem might be supported via Smartlink module, which I was able to compile. Well, as we sometimes learn, compiling isn’t everything. The module failed to load because it claimed to have some unresolved symbols. Great. Searching google, I’ve found a web site dealing with activating the modem on an ALSA based systems (sounds just like my case!) so I tried that direction as well. It was well documented withing the driver’s README itself. I’ve discovered one tweak, though. "make install" rebuilds the whole code. It’s like "make all" with the install part afterwards, so if you’re into it, make sure you read the damn README file, and type "make install SUPPORT_ALSA=1" right from the start. No luck, though, as there is no extra ALSA device, not after this procedure, and not after I rebuild the modules, per the instructions in the README file.

Just now I’ve tested an alternate method, as described in this website. It didn’t work either, but was another try, right?

Still, no PCI id for the modem. I might be searching in the wrong direction. Maybe it’s the ISA Bridge, and I’ll have to pinpoint it there. I can’t tell now. I will get back to it sometimes later.